Home > Unable To > Unable To Find The Qmake Tool For Qt4

Unable To Find The Qmake Tool For Qt4

Make sure that the qmake in your PATH links to the latest version of Qt you have installed. It usually contains the dependency on rest of the packages. NB: We warn against using tools that try to avoid installing the full Xcode by overwriting system files in /usr/bin, since that has caused problems for other users, forcing them to Information forwarded to [email protected], Debian Kernel Team : Bug#682726; Package linux-source-3.4. (Wed, 25 Jul 2012 03:15:03 GMT) Full text and rfc822 format available. http://amazonfonts.com/unable-to/unable-to-find-the-qt4-tool-qmake-trying-to-use-qt3.html

When I run "make xconfig" it answered me: I find "make menuconfig" better maintained. -- Cheers / Saludos, Carlos E. T3RM1NVT0R View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by T3RM1NVT0R 01-04-2012, 05:10 PM #3 doughyi8u Member Registered: Apr 2010 Posts: 227 I had the same problem when trying to install qBittorrent, and mine was solved with export QT_QMAKE=/usr/bin. Thread Tools Show Printable Version Subscribe to this Thread… Display Linear Mode Switch to Hybrid Mode Switch to Threaded Mode 07-May-2013,23:20 #1 zorkia View Profile View Forum Posts View Blog Entries

Browse other questions tagged qt ubuntu qmake or ask your own question. Qt 4 is several years old and contains a version of WebKit with many serious defects. Why are Stormtroopers stationed outside the Death Star near the turbolaser batteries adjacent to Bay 327? Password Linux - Newbie This Linux forum is for members that are new to Linux.

Check if you have the correct ppa in place for installing the dependencies. jepjep View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by jepjep 10-25-2016, 02:03 PM #11 Emerson LQ Guru Registered: Nov 2004 Location: make: *** [xconfig] Error 2 when I tried to install qt4-qmake through synaptic manager ; an error is displayed saying that tz_data not found. It only requires ncurses, which is probably already installed. --- rod.

Just say Y. Open the dmg files and install. Why is the movie called "Dirty Dancing"? https://forum.qt.io/topic/60542/can-t-find-installed-qt4-when-using-make-xconfig-command Otherwise compiling will result in precompiled header errors, and the QT_VERSION_CHECK macro will not be found.

R. (from 12.1 x86_64 "Asparagus" at Telcontar) Reply With Quote 09-May-2013,02:54 #4 zorkia View Profile View Forum Posts View Blog Entries View Articles Suspended Join Date Dec 2012 Posts 215 Re: Contact Us - Advertising Info - Rules - LQ Merchandise - Donations - Contributing Member - LQ Sitemap - Main Menu Linux Forum Android Forum Chrome OS Forum Search LQ Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox. make: *** [xconfig] Error 2 I tried installing libqt4-core but it still comes back with this same error.

Please make sure that * the QT4 or QT3 development package is correctly installed and * either qmake can be found or install pkg-config or set * the QTDIR environment variable http://blog.coffeebeans.at/archives/143 Reply Bor says: August 31, 2015 at 18:01 Thanks for this solution! Trying to use QT3 * * Unable to find any QT installation. Support for Qt 4 will be dropped in any future feature releases and is not supported by the capybara-webkit team.

dev? http://amazonfonts.com/unable-to/unable-to-locate-tool-jar.html Added tag(s) pending. Only users with topic management privileges can see it. Thanks for contributing!

Trying to use QT3 * * Unable to find any QT installation. Once installed via the package, one simply needs to set the QMAKE environment variable and bundle. Search for text in a file, then rename the file with that text What does "d" mean in definition of Double.NaN = 0.0d / 0.0? Source ty When in doubt, install dev.

qmake was a symlink to qtchooser which takes the -qt argument. OS X Lion 10.7 Homebrew Install Qt via homebrew. Alpine Linux 3.4 apk add qt5-qtwebkit-dev QMAKE=/usr/lib/qt5/bin/qmake gem install capybara-webkit FreeBSD If you know how to compile using Qt 5 under FreeBSD, please edit this page and add instructions.

Note: if using the official packages and the Xcode compiler, ensure that the command line tools are installed as well.

Ben Hutchings (supplier of updated linux package) (This message was generated automatically at their request; if you believe that there is a problem with it please contact the archive administrators Grab latest Qt Formula (newer than this commit: https://github.com/mxcl/homebrew/commit/2547ffd) Regular procedure is, first update the formulas, then try installing the built binary with: brew update brew install qt If linking fails, If you are interested in packaging an app you can also take a look at this blog post I made explaining how to do it share|improve this answer answered Nov 6 Acknowledgement sent to Ben Hutchings : Extra info received and forwarded to list.

This book contains many real life examples derived from the author's experience as a Linux system and network administrator, trainer and consultant. Request was from Jonathan Nieder to [email protected] (Mon, 03 Sep 2012 08:21:04 GMT) Full text and rfc822 format available. How to use a function definition in another function Can Mirror Image still work while being grappled? have a peek here Homebrew Install Qt via homebrew.

Request was from Ben Hutchings to [email protected] (Wed, 25 Jul 2012 03:27:03 GMT) Full text and rfc822 format available. Stop. share|improve this answer answered Apr 11 '15 at 22:02 Barry Kelly 33.7k474153 Perfect! Thank yor explanation about CODE tags, I did not know about it.

xconfig' command This topic has been deleted. Notification sent to Filipus Klutiero : Bug acknowledged by developer. (Tue, 18 Sep 2012 18:30:38 GMT) Full text and rfc822 format available. Stop. UbuntuCommunityAsk!DeveloperDesignDiscourseHardwareInsightsJujuShopMore ›AppsHelpForumLaunchpadMAASCanonical current community chat Ask Ubuntu Ask Ubuntu Meta your communities Sign up or log in to customize your list.

Adv Reply July 30th, 2011 #3 scorchgeek View Profile View Forum Posts Private Message Visit Homepage Gee! Ubuntu Trusty (14.04) sudo apt-get install libqt4-dev libqtwebkit-dev Fedora yum install qt-webkit-devel Fedora 16 If you know how to compile using Qt 5 under Fedora 16, please edit this page and share|improve this answer edited Aug 28 '15 at 16:23 answered May 17 '13 at 10:44 jtomaszk 1,0041131 2 Hi @Warthel4578, thanks, your answer helped me indirectly, since I installed qt4-qmake, The time now is 13:27. © 2015 SUSE, All Rights Reserved.

Reload to refresh your session. Goodness Thank you person. The flag is needed as qtwebkit is no longer included in Qt by default.